New PCI DSS 3.2 Service Provider Requirements in Effect – Are You Ready?

PCI Logo

AICPA Logo

Fedramp

Inc 5000 Logo

HITRUST

Align

ANAB

With the effective date of February 1, 2018, service providers must now adhere to the new PCI DSS Version 3.2 requirements.

To help prepare for these new service provider requirements, A-LIGN’s Senior Manager, Dustin Rich, will review the new PCI DSS 3.2 requirements including the segmentation testing requirements, outline how these changes might affect your organization, and provide actionable steps to ensure your PCI DSS compliance in 2018.

In this webinar, Dustin will examine industry trends, updated requirements, and best practices, as well as:

  • Review the recent changes and applicability of new requirements for Service Providers
  • Discuss the key differences between penetration testing and segmentation testing and applicable scenarios
  • Provide guidance on how to prepare for validation this coming year and meet the new requirements